我大概2020年的时候把小站从ZBlog ASP迁移到PHP版本,后来又在2024年迁移过一次服务器,从实体机迁移到了一台群晖NAS的虚拟机中,一直稳定运行到现在,最近仅仅更新了一些插件和服务器组件到最新版本,主要是为了安全。
其实在过去的20年时间中,小站已经历经过很多次迁移,比如换了新服务器、硬盘挂掉、或者心血来潮换个新操作系统等等。以前我只专注与使用asp版本的ZBlog,所以过去在迁移小站的时候,经常遇到ZBlog迁移的各种问题,很奇怪的是当时zblog官网都有很详细的迁移指导,但最近这些年,大概是已经放弃了ASP版本的缘故,在zblog官网上已经找不到ASP版本的迁移指导和各种问答了(也可能是我找的不仔细),总之2024年我把小站迁移到虚拟机中,虽然php的新版程序运行稳定良好,但虚拟机中Windows Server 2019再部署原先的ZBlog ASP就一直报错至今,就是一运行ZBlog各种asp脚本,就会遇到500错误。
可能就是自己比较懒的缘故,心想新版php程序运行正常,旧版asp虽然不能正常运行,但因为旧版小站做过html静态化处理,所以所有页面也可以正常访问,只是不能执行asp脚本罢了……从某些方面想,这其实更安全了。于是在解决问题方面浅尝辄止了一下,然后就抛之脑后了。
不过最近把一些运维工作托管给Workbuddy后,发现这小东西确实很省心,只要设定好条件和边界,基本上可以把大部分日常运维工作交给这种工具处理,于是我在虚拟机的Windows里安装了Workbuddy,让他给我解决ZBlog访问出现500错误……大概只过去10分钟,就解决了。
其实问题被解决到不是我最意外的,让我意外的是,问题原因是Windows新版IIS默认使用64位数据引擎,ZBlog ASP版本过去是为Windows 2000和Windows Server 2003这样的老旧操作系统设计的,默认使用32位数据引擎连接,在新版IIS中需要开启32位应用程序兼容。
而这个问题,实际上在我过去很多年使用过程中,特别是迁移小站的过程中其实遇到过好几次了……只是2024年这一次我在找解决方案的时候,压根没想起来需要开启这个设置,并且在官网上也没有找到相关条目……于是一直拖到现在,还是在Workbuddy的帮助下开启了这个小设置……解决问题后的我反而相当崩溃-。-



